Skip to content

← Actionable
Medium, CVSS 5.3

Knative Serving vulnerable to attacker-controlled pod causing denial of service of autoscaler

CVE-2023-48713GHSA-qmvj-4qr9-v547

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (knative.dev/serving 0.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-48713: 0.87% estimated exploitation activity in the next 30 days; percentile 58.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability was fond in Knative Serving that could allow an attacker to crash the Knative Serving autoscaler resulting in a denial of service. The attacker would need to have compromised one pod in the Knative Serving deployment, and with that position they could launch the attack against the autoscaler. When the autoscaler scrapes the metrics of pods, it sends a request to the /metrics endpoint of each pod and reads the response. The attacker would need to detect the request from the autoscaler to the /metrics endpoint of the pod they had compromised and send a malicious response back to the autoscaler. At this point, the autoscaler would crash. The root cause of the vulnerability was a memory exhaustion issue in the autoscaler that the attacker could trigger with the malicious reponse. The vulnerability would allow a privilege escalation by the attacker from controlling one point to having negative impact on the entire Knative Serving deployment. Impact All users are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qmvj-4qr9-v547

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-48713

Advisory: Knative Serving vulnerable to attacker-controlled pod causing denial of service of autoscaler
IDs: CVE-2023-48713, GHSA-qmvj-4qr9-v547
Record: https://patchnext.com/advisories/cve-2023-48713 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: knative.dev/serving 0.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go knative.dev/serving: affected < 0.39.0; fixed in 0.39.0

## Suggested inspection (read-only)
- Go knative.dev/serving: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on knative.dev/serving.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qmvj-4qr9-v547 (GitHub-reviewed advisory GHSA-qmvj-4qr9-v547 lists affected ranges: Go knative.dev/serving >=0 <0.39.0)

Commands are suggestions: review each one before running it.

Loading voting…