google-translate-api-browser Server-Side Request Forgery (SSRF) Vulnerability
CVE-2023-48711GHSA-4233-7q5q-m7p6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (google-translate-api-browser 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm google-translate-api-browser
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4233-7q5q-m7p6 lists affected ranges: npm google-translate-api-browser >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4233-7q5q-m7p6 lists affected ranges: npm google-translate-api-browser >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2023-48711: 0.49% estimated exploitation activity in the next 30 days; percentile 42.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Server-Side Request Forgery (SSRF) Vulnerability is present in applications utilizing the google-translate-api-browser package and exposing the translateOptions to the end user. An attacker can set a malicious tld, causing the application to return unsafe URLs pointing towards local resources. Details The translateOptions.tld field is not properly sanitized before being placed in the Google translate URL. This can allow an attacker with control over the translateOptions to set the tld to a payload such as @127.0.0.1. This causes the full URL to become https://translate.google.@127.0.0.1/..., where translate.google. is the username used to connect to localhost. PoC Imagine a server running the following code (closely mimicking the code present in the package's README): An attacker can then send the following POST request to /translate: This will cause a request to be sent to the localhost of the server running the Node application. Impact An attacker can send requests within…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4233-7q5q-m7p6
- Revision 1 · created ·
Published from osv record GHSA-4233-7q5q-m7p6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48711 Advisory: google-translate-api-browser Server-Side Request Forgery (SSRF) Vulnerability IDs: CVE-2023-48711, GHSA-4233-7q5q-m7p6 Record: https://patchnext.com/advisories/cve-2023-48711 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: google-translate-api-browser 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm google-translate-api-browser: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls google-translate-api-browser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on google-translate-api-browser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4233-7q5q-m7p6 (OSV record GHSA-4233-7q5q-m7p6 lists affected ranges: npm google-translate-api-browser >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4233-7q5q-m7p6 (GitHub-reviewed advisory GHSA-4233-7q5q-m7p6 lists affected ranges: npm google-translate-api-browser >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…