Insertion of Sensitive Information into Log
CVE-2023-48708GHSA-j72f-h752-mx4w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/shield 1.0.0-beta.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codeigniter4/shield
- Affected
- < 1.0.0-beta.8
- Fixed in
- 1.0.0-beta.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j72f-h752-mx4w lists affected ranges: Packagist codeigniter4/shield >=0 <1.0.0-beta.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-48708: 0.63% estimated exploitation activity in the next 30 days; percentile 50.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If successful login attempts are recorded, the raw tokens are stored in the log table. If a malicious person somehow views the data in the log table, he or she can obtain a raw token, which can then be used to send a request with that user's authority. When you (1) use the following authentiactors, - AccessTokens (tokens) - JWT (jwt) - HmacSha256 (hmac) and you (2) log successful login attempts, the raw tokens are stored. Patches Upgrade to Shield v1.0.0-beta.8 or later. Workarounds Disable logging for successful login attempts by the configuration files. - AccessTokens or HmacSha256 - Set Config\AuthToken::$recordLoginAttempt to Auth::RECORDLOGINATTEMPTFAILURE or Auth::RECORDLOGINATTEMPTNONE - JWT - Set Config\AuthJWT::$recordLoginAttempt to Auth::RECORDLOGINATTEMPTFAILURE or Auth::RECORDLOGINATTEMPTNONE References - https://codeigniter4.github.io/shield/gettingstarted/authenticators/ For more information If you have any questions or comments about this advisory: Open an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j72f-h752-mx4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48708 Advisory: Insertion of Sensitive Information into Log IDs: CVE-2023-48708, GHSA-j72f-h752-mx4w Record: https://patchnext.com/advisories/cve-2023-48708 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codeigniter4/shield 1.0.0-beta.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codeigniter4/shield: affected < 1.0.0-beta.8; fixed in 1.0.0-beta.8 ## Suggested inspection (read-only) - Packagist codeigniter4/shield: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codeigniter4/shield. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j72f-h752-mx4w (GitHub-reviewed advisory GHSA-j72f-h752-mx4w lists affected ranges: Packagist codeigniter4/shield >=0 <1.0.0-beta.8) Commands are suggestions: review each one before running it.
Loading voting…