Cleartext Storage of Sensitive Information in HMAC SHA256 Authentication
CVE-2023-48707GHSA-v427-c49j-8w6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/shield 1.0.0-beta.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codeigniter4/shield
- Affected
- < 1.0.0-beta.8
- Fixed in
- 1.0.0-beta.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v427-c49j-8w6x lists affected ranges: Packagist codeigniter4/shield >=0 <1.0.0-beta.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-48707: 0.28% estimated exploitation activity in the next 30 days; percentile 20.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact secretKey, an important key for HMAC SHA256 authentication, was stored in the database in raw form. If a malicious person somehow had access to the data in the database, they could use the key and secretKey for HMAC SHA256 authentication to send requests impersonating that person. Patches Upgrade to Shield v1.0.0-beta.8 or later. After upgrading, all existing secret keys must be encrypted. See https://github.com/codeigniter4/shield/blob/develop/UPGRADING.md for details. Workarounds None. References - https://codeigniter4.github.io/shield/references/authentication/hmac/ For more information If you have any questions or comments about this advisory: Open an issue or discussion in codeigniter4/shield Email us at security@codeigniter.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v427-c49j-8w6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48707 Advisory: Cleartext Storage of Sensitive Information in HMAC SHA256 Authentication IDs: CVE-2023-48707, GHSA-v427-c49j-8w6x Record: https://patchnext.com/advisories/cve-2023-48707 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codeigniter4/shield 1.0.0-beta.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codeigniter4/shield: affected < 1.0.0-beta.8; fixed in 1.0.0-beta.8 ## Suggested inspection (read-only) - Packagist codeigniter4/shield: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codeigniter4/shield. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v427-c49j-8w6x (GitHub-reviewed advisory GHSA-v427-c49j-8w6x lists affected ranges: Packagist codeigniter4/shield >=0 <1.0.0-beta.8) Commands are suggestions: review each one before running it.
Loading voting…