Skip to content

← Actionable
High, CVSS 7.1amended

Cross-site Scripting potential in custom links, job buttons, and computed fields

CVE-2023-48705GHSA-cf9f-wmhp-v4pr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nautobot 2.0.5, 1.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nautobot

    Affected
    < 1.6.6>= 2.0.0, < 2.0.5
    Fixed in
    1.6.6, 2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:L
EPSS
  • CVE-2023-48705: 0.54% estimated exploitation activity in the next 30 days; percentile 45.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected. Due to incorrect usage of Django's marksafe() API when rendering certain types of user-authored content, including: - custom links - job buttons - computed fields it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content. Patches Has the problem been patched? What versions should users upgrade to? We have fixed the incorrect uses of marksafe() (generally by replacing them with appropriate use of formathtml() instead) to prevent such malicious data from being executed. Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Appropriate object permissions can and should be applied to restrict which users…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cf9f-wmhp-v4pr

  2. Revision 1 · created ·

    Published from osv record GHSA-cf9f-wmhp-v4pr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-48705

Advisory: Cross-site Scripting potential in custom links, job buttons, and computed fields
IDs: CVE-2023-48705, GHSA-cf9f-wmhp-v4pr
Record: https://patchnext.com/advisories/cve-2023-48705 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nautobot 2.0.5, 1.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nautobot: affected < 1.6.6; >= 2.0.0, < 2.0.5; fixed in 1.6.6, 2.0.5

## Suggested inspection (read-only)
- `python -m pip show nautobot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nautobot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cf9f-wmhp-v4pr (OSV record GHSA-cf9f-wmhp-v4pr lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-cf9f-wmhp-v4pr (GitHub-reviewed advisory GHSA-cf9f-wmhp-v4pr lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.0.5)

Commands are suggestions: review each one before running it.

Loading voting…