Skip to content

← Actionable
High, CVSS 7.5

Cross-site Scripting via uploaded assets

CVE-2023-48701GHSA-8jjh-j3c2-cjcv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 4.36.0, 3.4.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist statamic/cms

    Affected
    < 3.4.15>= 4.0.0, < 4.36.0
    Fixed in
    3.4.15, 4.36.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:H
EPSS
  • CVE-2023-48701: 0.70% estimated exploitation activity in the next 30 days; percentile 53.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact HTML files crafted to look like images may be uploaded regardless of mime validation. This is only applicable on front-end forms using the "Forms" feature containing an assets field, or within the control panel which requires authentication. Patches It has been patched on 3.4.15 and 4.36.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8jjh-j3c2-cjcv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-48701

Advisory: Cross-site Scripting via uploaded assets
IDs: CVE-2023-48701, GHSA-8jjh-j3c2-cjcv
Record: https://patchnext.com/advisories/cve-2023-48701 (revision 1, source checked 26 Oct 2026, 14:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: statamic/cms 4.36.0, 3.4.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist statamic/cms: affected < 3.4.15; >= 4.0.0, < 4.36.0; fixed in 3.4.15, 4.36.0

## Suggested inspection (read-only)
- Packagist statamic/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on statamic/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8jjh-j3c2-cjcv (GitHub-reviewed advisory GHSA-8jjh-j3c2-cjcv lists affected ranges: Packagist statamic/cms >=0 =4.0.0 <4.36.0)

Commands are suggestions: review each one before running it.

Loading voting…