Skip to content

← Actionable
High, CVSS 8.4amended

Eval Injection in fastbots

CVE-2023-48699GHSA-vccg-f4gp-45x9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastbots 0.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fastbots

    Affected
    < 0.1.5
    Fixed in
    0.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-48699: 0.74% estimated exploitation activity in the next 30 days; percentile 54.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def locator(self, locatorname: str) in page.py. The vulnerable code that load and execute directly from the file without validation it's: Patches In order to mitigate this issue it's important to upgrade to fastbots version 0.1.5 or above. References Merge that fix also this issue

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vccg-f4gp-45x9

  2. Revision 1 · created ·

    Published from osv record GHSA-vccg-f4gp-45x9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-48699

Advisory: Eval Injection in fastbots
IDs: CVE-2023-48699, GHSA-vccg-f4gp-45x9
Record: https://patchnext.com/advisories/cve-2023-48699 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastbots 0.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastbots: affected < 0.1.5; fixed in 0.1.5

## Suggested inspection (read-only)
- `python -m pip show fastbots`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastbots.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vccg-f4gp-45x9 (OSV record GHSA-vccg-f4gp-45x9 lists affected ranges: PyPI fastbots >=0 <0.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-vccg-f4gp-45x9 (GitHub-reviewed advisory GHSA-vccg-f4gp-45x9 lists affected ranges: PyPI fastbots >=0 <0.1.5)

Commands are suggestions: review each one before running it.

Loading voting…