DockerSpawner allows any image by default
CVE-2023-48311GHSA-hfgr-h3vc-p6c2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dockerspawner 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dockerspawner
- Affected
- >= 0.11.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hfgr-h3vc-p6c2 lists affected ranges: PyPI dockerspawner >=0.11.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfgr-h3vc-p6c2 lists affected ranges: PyPI dockerspawner >=0.11.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-48311: 0.64% estimated exploitation activity in the next 30 days; percentile 50.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users of JupyterHub deployments running DockerSpawner starting with 0.11.0 without specifying DockerSpawner.allowedimages configuration allow users to launch any pullable image, instead of restricting to only the single configured image, as intended. Patches Upgrade to DockerSpawner 13. Workarounds Explicitly setting DockerSpawner.allowedimages to a non-empty list containing only the default image will result in the intended default behavior:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hfgr-h3vc-p6c2
- Revision 1 · created ·
Published from osv record GHSA-hfgr-h3vc-p6c2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48311 Advisory: DockerSpawner allows any image by default IDs: CVE-2023-48311, GHSA-hfgr-h3vc-p6c2 Record: https://patchnext.com/advisories/cve-2023-48311 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dockerspawner 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dockerspawner: affected >= 0.11.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - `python -m pip show dockerspawner`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dockerspawner. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hfgr-h3vc-p6c2 (OSV record GHSA-hfgr-h3vc-p6c2 lists affected ranges: PyPI dockerspawner >=0.11.0 <13.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hfgr-h3vc-p6c2 (GitHub-reviewed advisory GHSA-hfgr-h3vc-p6c2 lists affected ranges: PyPI dockerspawner >=0.11.0 <13.0.0) Commands are suggestions: review each one before running it.
Loading voting…