Run Shell Command allows Cross-Site Request Forgery
CVE-2023-48292GHSA-8jpr-ff92-hpf9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib:xwiki-application-admintools 4.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.contrib:xwiki-application-admintools
- Affected
- >= 4.4, < 4.5.1
- Fixed in
- 4.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8jpr-ff92-hpf9 lists affected ranges: Maven org.xwiki.contrib:xwiki-application-admintools >=4.4 <4.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-48292: 22.94% estimated exploitation activity in the next 30 days; percentile 97.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A cross site request forgery vulnerability in the admin tool for executing shell commands on the server allows an attacker to execute arbitrary shell commands by tricking an admin into loading the URL with the shell command. A very simple possibility for an attack are comments. When the attacker can leave a comment on any page in the wiki it is sufficient to include an image with an URL like /xwiki/bin/view/Admin/RunShellCommand?command=touch%20/tmp/attacked in the comment. When an admin views the comment, the file /tmp/attacked will be created on the server. The output of the command is also vulnerable to XWiki syntax injection which offers a simple way to execute Groovy in the context of the XWiki installation and thus an even easier way to compromise the integrity and confidentiality of the whole XWiki installation. Patches This has been patched by adding a form token check in version 4.5.1 of the admin tools. Workarounds The patch can be applied manually to the affected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8jpr-ff92-hpf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48292 Advisory: Run Shell Command allows Cross-Site Request Forgery IDs: CVE-2023-48292, GHSA-8jpr-ff92-hpf9 Record: https://patchnext.com/advisories/cve-2023-48292 (revision 1, source checked 26 Oct 2026, 16:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib:xwiki-application-admintools 4.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.contrib:xwiki-application-admintools: affected >= 4.4, < 4.5.1; fixed in 4.5.1 ## Suggested inspection (read-only) - Maven org.xwiki.contrib:xwiki-application-admintools: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.contrib:xwiki-application-admintools. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8jpr-ff92-hpf9 (GitHub-reviewed advisory GHSA-8jpr-ff92-hpf9 lists affected ranges: Maven org.xwiki.contrib:xwiki-application-admintools >=4.4 <4.5.1) Commands are suggestions: review each one before running it.
Loading voting…