Skip to content

← Actionable
High, CVSS 8.2amended

Ethyca Fides Cryptographically Weak Generation of One-Time Codes for Identity Verification

CVE-2023-48224GHSA-82vr-5769-6358

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.24.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2023-48224: 0.99% estimated exploitation activity in the next 30 days; percentile 62.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Fides Privacy Center allows data subject users to submit privacy and consent requests to data controller users of the Fides web application. Privacy requests allow data subjects to submit a request to access all person data held by the data controller, or delete/erase it. Consent request allows data subject users to modify their privacy preferences for how the data controller uses their personal data e.g. data sales and sharing consent opt-in/opt-out. If subjectidentityverificationrequired in the [execution] section of fides.toml or the env var FIDESEXECUTIONSUBJECTIDENTITYVERIFICATIONREQUIRED is set to True on the fides webserver backend, data subjects are sent a one-time code to their email address or phone number, depending on messaging configuration, and the one-time code must be entered in the Privacy Center UI by the data subject before the privacy or consent request is submitted. It was identified that the one-time code values for these requests were generated by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-82vr-5769-6358

  2. Revision 1 · created ·

    Published from osv record GHSA-82vr-5769-6358

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-48224

Advisory: Ethyca Fides Cryptographically Weak Generation of One-Time Codes for Identity Verification
IDs: CVE-2023-48224, GHSA-82vr-5769-6358
Record: https://patchnext.com/advisories/cve-2023-48224 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.24.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected < 2.24.0; fixed in 2.24.0

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-82vr-5769-6358 (OSV record GHSA-82vr-5769-6358 lists affected ranges: PyPI ethyca-fides >=0 <2.24.0 (fixed))
- Verified: https://github.com/advisories/GHSA-82vr-5769-6358 (GitHub-reviewed advisory GHSA-82vr-5769-6358 lists affected ranges: PyPI ethyca-fides >=0 <2.24.0)

Commands are suggestions: review each one before running it.

Loading voting…