Possibility to circumvent the invitation token expiry period
CVE-2023-48220GHSA-w3q8-m492-4pwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devise_invitable 2.0.9; decidim-admin 0.27.5, 0.26.9; decidim 0.27.5, 0.26.9; decidim-system 0.27.5, 0.26.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems devise_invitable
- Affected
- >= 0.4.rc3, < 2.0.9
- Fixed in
- 2.0.9
RubyGems decidim-admin
- Affected
- >= 0.0.1.alpha3, < 0.26.9>= 0.27.0, < 0.27.5
- Fixed in
- 0.27.5, 0.26.9
RubyGems decidim
- Affected
- >= 0.0.1.alpha3, < 0.26.9>= 0.27.0, < 0.27.5
- Fixed in
- 0.27.5, 0.26.9
RubyGems decidim-system
- Affected
- >= 0.0.1.alpha3, < 0.26.9>= 0.27.0, < 0.27.5
- Fixed in
- 0.27.5, 0.26.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3q8-m492-4pwp lists affected ranges: RubyGems decidim >=0.0.1.alpha3 =0.27.0 =0.0.1.alpha3 =0.27.0 =0.0.1.alpha3 =0.27.0 =0.4.rc3 <2.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-48220: 0.79% estimated exploitation activity in the next 30 days; percentile 56.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The invites feature allows users to accept the invitation for an unlimited amount of time through the password reset functionality. When using the password reset functionality, the deviseinvitable gem always accepts the pending invitation if the user has been invited as shown in this piece of code within the deviseinvitable gem: https://github.com/scambra/deviseinvitable/blob/41f58970ff76fb64382a9b9ea1bd530f7c3adab2/lib/deviseinvitable/models.rb#L198 The only check done here is if the user has been invited but the code does not ensure that the pending invitation is still valid as defined by the invitefor expiry period as explained in the gem's documentation: https://github.com/scambra/deviseinvitable#model-configuration- invitefor: The period the generated invitation token is valid. After this period, the invited resource won’t be able to accept the invitation. When invitefor is 0 (the default), the invitation won’t expire. Decidim sets this configuration to 2.weeks so this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3q8-m492-4pwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48220 Advisory: Possibility to circumvent the invitation token expiry period IDs: CVE-2023-48220, GHSA-w3q8-m492-4pwp Record: https://patchnext.com/advisories/cve-2023-48220 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devise_invitable 2.0.9; decidim-admin 0.27.5, 0.26.9; decidim 0.27.5, 0.26.9; decidim-system 0.27.5, 0.26.9. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems devise_invitable: affected >= 0.4.rc3, < 2.0.9; fixed in 2.0.9 - RubyGems decidim-admin: affected >= 0.0.1.alpha3, < 0.26.9; >= 0.27.0, < 0.27.5; fixed in 0.27.5, 0.26.9 - RubyGems decidim: affected >= 0.0.1.alpha3, < 0.26.9; >= 0.27.0, < 0.27.5; fixed in 0.27.5, 0.26.9 - RubyGems decidim-system: affected >= 0.0.1.alpha3, < 0.26.9; >= 0.27.0, < 0.27.5; fixed in 0.27.5, 0.26.9 ## Suggested inspection (read-only) - RubyGems devise_invitable: check the installed version with your package manager. - RubyGems decidim-admin: check the installed version with your package manager. - RubyGems decidim: check the installed version with your package manager. - RubyGems decidim-system: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devise_invitable, decidim-admin, decidim, decidim-system. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3q8-m492-4pwp (GitHub-reviewed advisory GHSA-w3q8-m492-4pwp lists affected ranges: RubyGems decidim >=0.0.1.alpha3 =0.27.0 =0.0.1.alpha3 =0.27.0 =0.0.1.alpha3 =0.27.0 =0.4.rc3 <2.0.9) Commands are suggestions: review each one before running it.
Loading voting…