TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodes
CVE-2023-48219GHSA-v626-r774-j7f8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 6.7.3, 5.10.9; tinymce/tinymce 6.7.3, 5.10.9; tinymce 6.7.3, 5.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tinymce
- Affected
- < 5.10.9>= 6.0.0, < 6.7.3
- Fixed in
- 5.10.9, 6.7.3
Packagist tinymce/tinymce
- Affected
- < 5.10.9>= 6.0.0, < 6.7.3
- Fixed in
- 5.10.9, 6.7.3
npm tinymce
- Affected
- < 5.10.9>= 6.0.0, < 6.7.3
- Fixed in
- 5.10.9, 6.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v626-r774-j7f8 lists affected ranges: npm tinymce >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v626-r774-j7f8 lists affected ranges: npm tinymce >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-48219: 0.71% estimated exploitation activity in the next 30 days; percentile 53.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. Such mutations occur when serialised HTML content is processed before being stored in the undo stack, or when the following APIs and plugins are used: tinymce.Editor.getContent({ format: 'raw' }) tinymce.Editor.resetContent() Autosave Plugin Patches This vulnerability has been patched in TinyMCE 6.7.3 by: ensuring that any unescaped text nodes which contain the special internal marker are emptied…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v626-r774-j7f8
- Revision 1 · created ·
Published from osv record GHSA-v626-r774-j7f8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48219 Advisory: TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodes IDs: CVE-2023-48219, GHSA-v626-r774-j7f8 Record: https://patchnext.com/advisories/cve-2023-48219 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 6.7.3, 5.10.9; tinymce/tinymce 6.7.3, 5.10.9; tinymce 6.7.3, 5.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tinymce: affected < 5.10.9; >= 6.0.0, < 6.7.3; fixed in 5.10.9, 6.7.3 - Packagist tinymce/tinymce: affected < 5.10.9; >= 6.0.0, < 6.7.3; fixed in 5.10.9, 6.7.3 - npm tinymce: affected < 5.10.9; >= 6.0.0, < 6.7.3; fixed in 5.10.9, 6.7.3 ## Suggested inspection (read-only) - NuGet tinymce: check the installed version with your package manager. - Packagist tinymce/tinymce: check the installed version with your package manager. - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce, tinymce/tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v626-r774-j7f8 (OSV record GHSA-v626-r774-j7f8 lists affected ranges: npm tinymce >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-v626-r774-j7f8 (GitHub-reviewed advisory GHSA-v626-r774-j7f8 lists affected ranges: npm tinymce >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.7.3) Commands are suggestions: review each one before running it.
Loading voting…