Statamic CMS vulnerable to remote code execution via form uploads
CVE-2023-48217GHSA-2r53-9295-3m86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 4.34.0, 3.4.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- >= 4.0.0, < 4.34.0< 3.4.14
- Fixed in
- 3.4.14, 4.34.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r53-9295-3m86 lists affected ranges: Packagist statamic/cms >=4.0.0 =0 <3.4.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-48217: 1.10% estimated exploitation activity in the next 30 days; percentile 65.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Similar to another advisory, certain additional PHP files crafted to look like images may be uploaded regardless of mime type validation rules. This affects front-end forms using the "Forms" feature, and asset upload fields in the control panel. Patches It has been patched in 3.4.14 and 4.34.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2r53-9295-3m86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-48217 Advisory: Statamic CMS vulnerable to remote code execution via form uploads IDs: CVE-2023-48217, GHSA-2r53-9295-3m86 Record: https://patchnext.com/advisories/cve-2023-48217 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 4.34.0, 3.4.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected >= 4.0.0, < 4.34.0; < 3.4.14; fixed in 3.4.14, 4.34.0 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2r53-9295-3m86 (GitHub-reviewed advisory GHSA-2r53-9295-3m86 lists affected ranges: Packagist statamic/cms >=4.0.0 =0 <3.4.14) Commands are suggestions: review each one before running it.
Loading voting…