Skip to content

← Actionable
High, CVSS 7.5amended

Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)

CVE-2023-4785GHSA-p25m-jpj4-qcrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (grpc 1.56.2, 1.55.3, 1.54.3, 1.53.2; grpcio 1.55.3, 1.54.3, 1.53.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems grpc

    Affected
    >= 1.56.0, < 1.56.2>= 1.55.0, < 1.55.3>= 1.54.0, < 1.54.3>= 1.53.0, < 1.53.2
    Fixed in
    1.54.3, 1.55.3, 1.53.2, 1.56.2
  • PyPI grpcio

    Affected
    >= 1.55.0, < 1.55.3>= 1.54.0, < 1.54.3>= 1.53.0, < 1.53.2
    Fixed in
    1.54.3, 1.55.3, 1.53.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-4785: 0.77% estimated exploitation activity in the next 30 days; percentile 55.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p25m-jpj4-qcrr

  2. Revision 1 · created ·

    Published from osv record GHSA-p25m-jpj4-qcrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-4785

Advisory: Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)
IDs: CVE-2023-4785, GHSA-p25m-jpj4-qcrr
Record: https://patchnext.com/advisories/cve-2023-4785 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: grpc 1.56.2, 1.55.3, 1.54.3, 1.53.2; grpcio 1.55.3, 1.54.3, 1.53.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems grpc: affected >= 1.56.0, < 1.56.2; >= 1.55.0, < 1.55.3; >= 1.54.0, < 1.54.3; >= 1.53.0, < 1.53.2; fixed in 1.54.3, 1.55.3, 1.53.2, 1.56.2
- PyPI grpcio: affected >= 1.55.0, < 1.55.3; >= 1.54.0, < 1.54.3; >= 1.53.0, < 1.53.2; fixed in 1.54.3, 1.55.3, 1.53.2

## Suggested inspection (read-only)
- RubyGems grpc: check the installed version with your package manager.
- `python -m pip show grpcio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on grpc, grpcio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p25m-jpj4-qcrr (OSV record GHSA-p25m-jpj4-qcrr lists affected ranges: RubyGems grpc >=1.56.0 =1.55.0 =1.54.0 =1.53.0 =1.55.0 =1.54.0 =1.53.0 <1.53.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p25m-jpj4-qcrr (GitHub-reviewed advisory GHSA-p25m-jpj4-qcrr lists affected ranges: RubyGems grpc >=1.56.0 =1.55.0 =1.54.0 =1.53.0 =1.55.0 =1.54.0 =1.53.0 <1.53.2)

Commands are suggestions: review each one before running it.

Loading voting…