API Platform Core can leak exceptions message that may contain sensitive information
CVE-2023-47639GHSA-rfw5-cqjj-7v9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 3.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist api-platform/core
- Affected
- >= 3.2.0, < 3.2.5
- Fixed in
- 3.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfw5-cqjj-7v9r lists affected ranges: Packagist api-platform/core >=3.2.0 <3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-47639: 0.39% estimated exploitation activity in the next 30 days; percentile 32.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Exception messages, that are not HTTP exceptions, are visible in the JSON error response. Details While we wanted to make our errors compatible with the JSON Problem specification, we ended up handling more exceptions then we did previously (introduced at https://github.com/api-platform/core/pull/5823). Instead of leaving that to Symfony, we ended up serializing errors with our normalizers which lead to not hiding the exception details. Note that the trace is hidden in production but the message is not, and the message can contain sensitive information. PoC At https://github.com/ili101/api-platform/tree/test3.2 it triggers an authentication exception as LDAP is not reachable. You can find the message available as a JSON response when trying to reach an endpoint. Impact Version 3.2 until 3.2.4 is impacted.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rfw5-cqjj-7v9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47639 Advisory: API Platform Core can leak exceptions message that may contain sensitive information IDs: CVE-2023-47639, GHSA-rfw5-cqjj-7v9r Record: https://patchnext.com/advisories/cve-2023-47639 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: api-platform/core 3.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist api-platform/core: affected >= 3.2.0, < 3.2.5; fixed in 3.2.5 ## Suggested inspection (read-only) - Packagist api-platform/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on api-platform/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfw5-cqjj-7v9r (GitHub-reviewed advisory GHSA-rfw5-cqjj-7v9r lists affected ranges: Packagist api-platform/core >=3.2.0 <3.2.5) Commands are suggestions: review each one before running it.
Loading voting…