Skip to content

← Actionable
High, CVSS 8.8

Pimcore SQL Injection in Admin Grid Filter API through Multiselect::getFilterConditionExt()

CVE-2023-47637GHSA-72hh-xf79-429p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 11.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-47637: 1.22% estimated exploitation activity in the next 30 days; percentile 68.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary User input passed directly into an SQL statement allows (non-admin) backend users to execute arbitrary SQL statements. Details The /admin/object/grid-proxy endpoint calls getFilterCondition() on fields of classes to be filtered for at https://github.com/pimcore/admin-ui-classic-bundle/blob/bba7c7419cb1f06d5fd98781eab4d6995e4e5dca/src/Helper/GridHelperService.php#L311, passing input from the request, and later executes the returned SQL. One implementation of getFilterCondition() is in Multiselect, which does not normalize/escape/validate the passed value: https://github.com/pimcore/pimcore/blob/42b6cfa77c4540205bdd10689893ccb73e4bac8f/models/DataObject/ClassDefinition/Data/Multiselect.php#L285-L312 PoC Set up an example project as described on https://pimcore.com/docs/platform/Pimcore/GettingStarted/Installation/DockerBasedInstallation (demo package with example content) Enter the backend and add a new user without admin privileges, but the "Objects" permission enabled. Log…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-72hh-xf79-429p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-47637

Advisory: Pimcore SQL Injection in Admin Grid Filter API through Multiselect::getFilterConditionExt()
IDs: CVE-2023-47637, GHSA-72hh-xf79-429p
Record: https://patchnext.com/advisories/cve-2023-47637 (revision 1, source checked 26 Oct 2026, 14:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 11.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected < 11.1.1; fixed in 11.1.1

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-72hh-xf79-429p (GitHub-reviewed advisory GHSA-72hh-xf79-429p lists affected ranges: Packagist pimcore/pimcore >=0 <11.1.1)

Commands are suggestions: review each one before running it.

Loading voting…