Possible CSRF attack at questionnaire templates preview
CVE-2023-47635GHSA-f3qm-vfc3-jg6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-templates 0.27.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-templates
- Affected
- >= 0.23.0, < 0.27.5
- Fixed in
- 0.27.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3qm-vfc3-jg6v lists affected ranges: RubyGems decidim-templates >=0.23.0 <0.27.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-47635: 0.31% estimated exploitation activity in the next 30 days; percentile 24.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The CSRF authenticity token check is currently disabled for the questionnaire templates preview as per: https://github.com/decidim/decidim/blob/3187bdfd40ea1c57c2c12512b09a7fec0b2bed08/decidim-templates/app/controllers/decidim/templates/admin/questionnairetemplatescontroller.rb#L11 This was introduced by this commit in the PR that introduced this feature (#6247): https://github.com/decidim/decidim/pull/6247/commits/5542227be66e3b6d7530f5b536069bce09376660 The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. Patches #11743 Workarounds Disable the templates functionality or remove all available templates. References #11743
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f3qm-vfc3-jg6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47635 Advisory: Possible CSRF attack at questionnaire templates preview IDs: CVE-2023-47635, GHSA-f3qm-vfc3-jg6v Record: https://patchnext.com/advisories/cve-2023-47635 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-templates 0.27.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-templates: affected >= 0.23.0, < 0.27.5; fixed in 0.27.5 ## Suggested inspection (read-only) - RubyGems decidim-templates: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f3qm-vfc3-jg6v (GitHub-reviewed advisory GHSA-f3qm-vfc3-jg6v lists affected ranges: RubyGems decidim-templates >=0.23.0 <0.27.5) Commands are suggestions: review each one before running it.
Loading voting…