AIOHTTP has problems in HTTP parser (the python one, not llhttp)
CVE-2023-47627GHSA-gfw2-4jvh-wgfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.8.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aiohttp
- Affected
- < 3.8.6
- Fixed in
- 3.8.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gfw2-4jvh-wgfg lists affected ranges: PyPI aiohttp >=0 <3.8.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfw2-4jvh-wgfg lists affected ranges: PyPI aiohttp >=0 <3.8.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-47627: 0.86% estimated exploitation activity in the next 30 days; percentile 58.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The HTTP parser in AIOHTTP has numerous problems with header parsing, which could lead to request smuggling. This parser is only used when AIOHTTPNOEXTENSIONS is enabled (or not using a prebuilt wheel). Details Bug 1: Bad parsing of Content-Length values Description RFC 9110 says this: Content-Length = 1DIGIT AIOHTTP does not enforce this rule, presumably because of an incorrect usage of the builtin int constructor. Because the int constructor accepts + and - prefixes, and digit-separating underscores, using int to parse CL values leads AIOHTTP to significant misinterpretation. Examples Suggested action Verify that a Content-Length value consists only of ASCII digits before parsing, as the standard requires. Bug 2: Improper handling of NUL, CR, and LF in header values Description RFC 9110 says this: Field values containing CR, LF, or NUL characters are invalid and dangerous, due to the varying ways that implementations might parse and interpret those characters; a recipient…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gfw2-4jvh-wgfg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-gfw2-4jvh-wgfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47627 Advisory: AIOHTTP has problems in HTTP parser (the python one, not llhttp) IDs: CVE-2023-47627, GHSA-gfw2-4jvh-wgfg Record: https://patchnext.com/advisories/cve-2023-47627 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.8.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aiohttp: affected < 3.8.6; fixed in 3.8.6 ## Suggested inspection (read-only) - `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aiohttp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gfw2-4jvh-wgfg (OSV record GHSA-gfw2-4jvh-wgfg lists affected ranges: PyPI aiohttp >=0 <3.8.6 (fixed)) - Verified: https://github.com/advisories/GHSA-gfw2-4jvh-wgfg (GitHub-reviewed advisory GHSA-gfw2-4jvh-wgfg lists affected ranges: PyPI aiohttp >=0 <3.8.6) Commands are suggestions: review each one before running it.
Loading voting…