Skip to content

← Actionable
Medium, CVSS 5.4amended

Apache Airflow has a stored cross-site scripting vulnerability

CVE-2023-47265GHSA-pxch-wr7m-rwxj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.8.0b1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-47265: 1.34% estimated exploitation activity in the next 30 days; percentile 71.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pxch-wr7m-rwxj

  2. Revision 1 · created ·

    Published from osv record GHSA-pxch-wr7m-rwxj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-47265

Advisory: Apache Airflow has a stored cross-site scripting vulnerability
IDs: CVE-2023-47265, GHSA-pxch-wr7m-rwxj
Record: https://patchnext.com/advisories/cve-2023-47265 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.8.0b1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 2.6.0, <= 2.7.3; fixed in 2.8.0b1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pxch-wr7m-rwxj (OSV record GHSA-pxch-wr7m-rwxj lists affected ranges: PyPI apache-airflow >=2.6.0 <2.8.0b1 (fixed))
- Verified: https://github.com/advisories/GHSA-pxch-wr7m-rwxj (GitHub-reviewed advisory GHSA-pxch-wr7m-rwxj lists affected ranges: PyPI apache-airflow >=2.6.0 <=2.7.3)

Commands are suggestions: review each one before running it.

Loading voting…