TYPO3 vulnerable to Weak Authentication in Session Handling
CVE-2023-47127GHSA-3vmm-7h4j-69rm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 12.4.8, 11.5.33, 10.4.41, 9.5.44, 8.7.55), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 8.0.0, <= 8.7.54>= 9.0.0, <= 9.5.43>= 10.0.0, <= 10.4.40>= 11.0.0, <= 11.5.32>= 12.0.0, <= 12.4.7
- Fixed in
- 8.7.55, 10.4.41, 11.5.33, 12.4.8, 9.5.44
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3vmm-7h4j-69rm lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 <=12.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-47127: 0.56% estimated exploitation activity in the next 30 days; percentile 46.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CVSS: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N/E:X/RL:O/RC:C (4.0) Problem Given that there are at least two different sites in the same TYPO3 installation - for instance first.example.org and second.example.com - then a session cookie generated for the first site can be reused on the second site without requiring additional authentication. This vulnerability primarily affects the frontend of the website. It's important to note that exploiting this vulnerability requires a valid user account. Solution Update to TYPO3 versions 8.7.55 ELTS, 9.5.44 ELTS, 10.4.41 ELTS, 11.5.33, 12.4.8 that fix the problem described above. Credits Thanks to Rémy Daniel who reported this issue, and to TYPO3 core & security team member Benjamin Franzke who fixed the issue. References TYPO3-CORE-SA-2023-006
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3vmm-7h4j-69rm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47127 Advisory: TYPO3 vulnerable to Weak Authentication in Session Handling IDs: CVE-2023-47127, GHSA-3vmm-7h4j-69rm Record: https://patchnext.com/advisories/cve-2023-47127 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 12.4.8, 11.5.33, 10.4.41, 9.5.44, 8.7.55. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 8.0.0, <= 8.7.54; >= 9.0.0, <= 9.5.43; >= 10.0.0, <= 10.4.40; >= 11.0.0, <= 11.5.32; >= 12.0.0, <= 12.4.7; fixed in 8.7.55, 10.4.41, 11.5.33, 12.4.8, 9.5.44 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3vmm-7h4j-69rm (GitHub-reviewed advisory GHSA-3vmm-7h4j-69rm lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 <=12.4.7) Commands are suggestions: review each one before running it.
Loading voting…