Skip to content

← Actionable
High, CVSS 7.1amended

Cross-site Scripting Vulnerability on Avatar Upload

CVE-2023-47115GHSA-q68h-xwq5-mm7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (label-studio 1.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2023-47115: 1.45% estimated exploitation activity in the next 30 days; percentile 73.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Introduction This write-up describes a vulnerability found in Label Studio, a popular open source data labeling tool. The vulnerability affects all versions of Label Studio prior to 1.9.2 and was tested on version 1.8.2. Overview Label Studio has a cross-site scripting (XSS) vulnerability that could be exploited when an authenticated user uploads a crafted image file for their avatar that gets rendered as a HTML file on the website. Description The following code snippet in Label Studio shows that the only verification check is that the file is an image by extracting the dimensions from the file. 1. Attempts to get image dimensions to validate the uploaded avatar file is an image. 2. Extracts the Content-Type from the upload POST request. A user can easily bypass this verification by changing the mimetype of the uploaded file to an allowed type (eg. image/jpeg). 3. The file extension of the uploaded file is never validated and is saved to the filesystem. Label Studio serves avatar…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q68h-xwq5-mm7x

  2. Revision 1 · created ·

    Published from osv record GHSA-q68h-xwq5-mm7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-47115

Advisory: Cross-site Scripting Vulnerability on Avatar Upload
IDs: CVE-2023-47115, GHSA-q68h-xwq5-mm7x
Record: https://patchnext.com/advisories/cve-2023-47115 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: label-studio 1.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI label-studio: affected < 1.9.2; fixed in 1.9.2

## Suggested inspection (read-only)
- `python -m pip show label-studio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on label-studio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q68h-xwq5-mm7x (OSV record GHSA-q68h-xwq5-mm7x lists affected ranges: PyPI label-studio >=0 <1.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-q68h-xwq5-mm7x (GitHub-reviewed advisory GHSA-q68h-xwq5-mm7x lists affected ranges: PyPI label-studio >=0 <1.9.2)

Commands are suggestions: review each one before running it.

Loading voting…