Ethyca Fides HTML Injection Vulnerability in HTML-Formatted DSR Packages
CVE-2023-47114GHSA-3vpf-mcj7-5h38
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.23.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- >= 2.15.1, < 2.23.3
- Fixed in
- 2.23.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3vpf-mcj7-5h38 lists affected ranges: PyPI ethyca-fides >=2.15.1 <2.23.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3vpf-mcj7-5h38 lists affected ranges: PyPI ethyca-fides >=2.15.1 <2.23.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-47114: 0.61% estimated exploitation activity in the next 30 days; percentile 49.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Fides web application allows data subject users to request access to their personal data. If the request is approved by the data controller user operating the Fides web application, the data subject's personal data can then retrieved from connected systems and data stores before being bundled together as a data subject access request package for the data subject to download. Supported data formats for the package include json and csv, but the most commonly used format is a series of HTML files compressed in a ZIP file. Once downloaded and unzipped, the data subject user can browse the HTML files on their local machine. It was identified that there was no validation of input coming from e.g. the connected systems and data stores which is later reflected in the downloaded data. This can result in an HTML injection that can be abused e.g. for phishing attacks or malicious JavaScript code execution, but only in the context of the data subject's browser accessing a HTML page…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3vpf-mcj7-5h38
- Revision 1 · created ·
Published from osv record GHSA-3vpf-mcj7-5h38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47114 Advisory: Ethyca Fides HTML Injection Vulnerability in HTML-Formatted DSR Packages IDs: CVE-2023-47114, GHSA-3vpf-mcj7-5h38 Record: https://patchnext.com/advisories/cve-2023-47114 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.23.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected >= 2.15.1, < 2.23.3; fixed in 2.23.3 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3vpf-mcj7-5h38 (OSV record GHSA-3vpf-mcj7-5h38 lists affected ranges: PyPI ethyca-fides >=2.15.1 <2.23.3 (fixed)) - Verified: https://github.com/advisories/GHSA-3vpf-mcj7-5h38 (GitHub-reviewed advisory GHSA-3vpf-mcj7-5h38 lists affected ranges: PyPI ethyca-fides >=2.15.1 <2.23.3) Commands are suggestions: review each one before running it.
Loading voting…