NATS.io: Adding accounts for just the system account adds auth bypass
CVE-2023-47090GHSA-fr2g-9hjm-wr23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/nats-io/nats-server/v2 2.10.2, 2.9.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/nats-io/nats-server/v2
- Affected
- >= 2.2.0, < 2.9.23>= 2.10.0, < 2.10.2
- Fixed in
- 2.10.2, 2.9.23
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr2g-9hjm-wr23 lists affected ranges: Go github.com/nats-io/nats-server/v2 >=2.2.0 =2.10.0 <2.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-47090: 0.83% estimated exploitation activity in the next 30 days; percentile 57.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Background NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing. NATS users exist within accounts, and once using accounts, the old authorization block is not applicable. Problem Description Without any authorization rules in the nats-server, users can connect without authentication. Before nats-server 2.2.0, all authentication and authorization rules for a nats-server lived in an "authorization" block, defining users. With nats-server 2.2.0 all users live inside accounts. When using the authorization block, whose syntax predates this, those users will be placed into the implicit global account, "$G". Users inside accounts go into the newer "accounts" block. If an "accounts" block is defined, in simple deployment scenarios this is often used only to enable client access to the system account. When the only account added is the system account "$SYS", the nats-server would create an implicit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fr2g-9hjm-wr23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-47090 Advisory: NATS.io: Adding accounts for just the system account adds auth bypass IDs: CVE-2023-47090, GHSA-fr2g-9hjm-wr23 Record: https://patchnext.com/advisories/cve-2023-47090 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/nats-io/nats-server/v2 2.10.2, 2.9.23. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/nats-io/nats-server/v2: affected >= 2.2.0, < 2.9.23; >= 2.10.0, < 2.10.2; fixed in 2.10.2, 2.9.23 ## Suggested inspection (read-only) - Go github.com/nats-io/nats-server/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/nats-io/nats-server/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fr2g-9hjm-wr23 (GitHub-reviewed advisory GHSA-fr2g-9hjm-wr23 lists affected ranges: Go github.com/nats-io/nats-server/v2 >=2.2.0 =2.10.0 <2.10.2) Commands are suggestions: review each one before running it.
Loading voting…