Account TakeOver Due to Improper Handling of JWT Tokens in usememos/memos
CVE-2023-4696GHSA-j2gj-g3p9-7mrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/usememos/memos 0.13.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.13.2
- Fixed in
- 0.13.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j2gj-g3p9-7mrr lists affected ranges: Go github.com/usememos/memos >=0 <0.13.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-4696: 1.12% estimated exploitation activity in the next 30 days; percentile 66.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Access Control in GitHub repository usememos/memos prior to 0.13.2. As of commit c9aa2eeb9 access tokens which fail validation are rejected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j2gj-g3p9-7mrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4696 Advisory: Account TakeOver Due to Improper Handling of JWT Tokens in usememos/memos IDs: CVE-2023-4696, GHSA-j2gj-g3p9-7mrr Record: https://patchnext.com/advisories/cve-2023-4696 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/usememos/memos 0.13.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/usememos/memos: affected < 0.13.2; fixed in 0.13.2 ## Suggested inspection (read-only) - Go github.com/usememos/memos: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/usememos/memos. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j2gj-g3p9-7mrr (GitHub-reviewed advisory GHSA-j2gj-g3p9-7mrr lists affected ranges: Go github.com/usememos/memos >=0 <0.13.2) Commands are suggestions: review each one before running it.
Loading voting…