Cross Site Scripting vulnerability in Contribsys Sidekiq
CVE-2023-46950GHSA-fhx8-5c23-x7x5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sidekiq-unique-jobs 8.0.7, 7.1.33), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sidekiq-unique-jobs
- Affected
- >= 8.0.0, < 8.0.7< 7.1.33
- Fixed in
- 8.0.7, 7.1.33
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fhx8-5c23-x7x5 lists affected ranges: RubyGems sidekiq-unique-jobs >=8.0.0 =0 <7.1.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-46950: 0.60% estimated exploitation activity in the next 30 days; percentile 48.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Scripting vulnerability in Contribsys Sidekiq v.6.5.8 allows a remote attacker to obtain sensitive information via a crafted URL to the filter functions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fhx8-5c23-x7x5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46950 Advisory: Cross Site Scripting vulnerability in Contribsys Sidekiq IDs: CVE-2023-46950, GHSA-fhx8-5c23-x7x5 Record: https://patchnext.com/advisories/cve-2023-46950 (revision 1, source checked 26 Oct 2026, 15:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sidekiq-unique-jobs 8.0.7, 7.1.33. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sidekiq-unique-jobs: affected >= 8.0.0, < 8.0.7; < 7.1.33; fixed in 8.0.7, 7.1.33 ## Suggested inspection (read-only) - RubyGems sidekiq-unique-jobs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sidekiq-unique-jobs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fhx8-5c23-x7x5 (GitHub-reviewed advisory GHSA-fhx8-5c23-x7x5 lists affected ranges: RubyGems sidekiq-unique-jobs >=8.0.0 =0 <7.1.33) Commands are suggestions: review each one before running it.
Loading voting…