Symfony potential Cross-site Scripting in WebhookController
CVE-2023-46735GHSA-72x2-5c85-6wmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 6.3.8; symfony/webhook 6.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 6.3.0, < 6.3.8
- Fixed in
- 6.3.8
Packagist symfony/webhook
- Affected
- >= 6.3.0, < 6.3.8
- Fixed in
- 6.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72x2-5c85-6wmr lists affected ranges: Packagist symfony/webhook >=6.3.0 =6.3.0 <6.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-46735: 0.57% estimated exploitation activity in the next 30 days; percentile 47.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The error message in WebhookController returns unescaped user-submitted input. Resolution WebhookController now doesn't return any user-submitted input in its response. The patch for this issue is available here for branch 6.3. Credits We would like to thank Maxime Aknin for reporting the issue and to Nicolas Grekas for providing the fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72x2-5c85-6wmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46735 Advisory: Symfony potential Cross-site Scripting in WebhookController IDs: CVE-2023-46735, GHSA-72x2-5c85-6wmr Record: https://patchnext.com/advisories/cve-2023-46735 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 6.3.8; symfony/webhook 6.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 6.3.0, < 6.3.8; fixed in 6.3.8 - Packagist symfony/webhook: affected >= 6.3.0, < 6.3.8; fixed in 6.3.8 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/webhook: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/webhook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72x2-5c85-6wmr (GitHub-reviewed advisory GHSA-72x2-5c85-6wmr lists affected ranges: Packagist symfony/webhook >=6.3.0 =6.3.0 <6.3.8) Commands are suggestions: review each one before running it.
Loading voting…