Jenkins lambdatest-automation Plugin may expose Credentials access token
CVE-2023-46653GHSA-hpv3-f5p7-pxj9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:lambdatest-automation 1.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:lambdatest-automation
- Affected
- < 1.21.0
- Fixed in
- 1.21.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hpv3-f5p7-pxj9 lists affected ranges: Maven org.jenkins-ci.plugins:lambdatest-automation >=0 <1.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-46653: 0.44% estimated exploitation activity in the next 30 days; percentile 38.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins lambdatest-automation Plugin 1.20.10 and earlier logs LAMBDATEST Credentials access token at the INFO level. This can result in accidental exposure of the token through the default system log. lambdatest-automation Plugin 1.21.0 no longer logs LAMBDATEST Credentials access token.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hpv3-f5p7-pxj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46653 Advisory: Jenkins lambdatest-automation Plugin may expose Credentials access token IDs: CVE-2023-46653, GHSA-hpv3-f5p7-pxj9 Record: https://patchnext.com/advisories/cve-2023-46653 (revision 1, source checked 26 Oct 2026, 16:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:lambdatest-automation 1.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:lambdatest-automation: affected < 1.21.0; fixed in 1.21.0 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:lambdatest-automation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:lambdatest-automation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hpv3-f5p7-pxj9 (GitHub-reviewed advisory GHSA-hpv3-f5p7-pxj9 lists affected ranges: Maven org.jenkins-ci.plugins:lambdatest-automation >=0 <1.21.0) Commands are suggestions: review each one before running it.
Loading voting…