Stored XSS vulnerability in Jenkins GitHub Plugin
CVE-2023-46650GHSA-mv77-fj63-q5w8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.coravy.hudson.plugins.github:github 1.37.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.coravy.hudson.plugins.github:github
- Affected
- < 1.37.3.1
- Fixed in
- 1.37.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mv77-fj63-q5w8 lists affected ranges: Maven com.coravy.hudson.plugins.github:github >=0 <1.37.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-46650: 0.72% estimated exploitation activity in the next 30 days; percentile 54.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins GitHub Plugin 1.37.3 and earlier does not escape the GitHub project URL on the build page when showing changes. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. GitHub Plugin 1.37.3.1 escapes GitHub project URL on the build page when showing changes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mv77-fj63-q5w8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46650 Advisory: Stored XSS vulnerability in Jenkins GitHub Plugin IDs: CVE-2023-46650, GHSA-mv77-fj63-q5w8 Record: https://patchnext.com/advisories/cve-2023-46650 (revision 1, source checked 26 Oct 2026, 16:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.coravy.hudson.plugins.github:github 1.37.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.coravy.hudson.plugins.github:github: affected < 1.37.3.1; fixed in 1.37.3.1 ## Suggested inspection (read-only) - Maven com.coravy.hudson.plugins.github:github: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.coravy.hudson.plugins.github:github. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mv77-fj63-q5w8 (GitHub-reviewed advisory GHSA-mv77-fj63-q5w8 lists affected ranges: Maven com.coravy.hudson.plugins.github:github >=0 <1.37.3.1) Commands are suggestions: review each one before running it.
Loading voting…