Skip to content

← Actionable
High, CVSS 7.5

Apache Tomcat Improper Input Validation vulnerability

CVE-2023-46589GHSA-fccv-jmmp-qg76

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96; org.apache.tomcat:tomcat-coyote 11.0.0-M11; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-fccv-jmmp-qg76 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 <11.0.0-M11

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-46589: 2.65% estimated exploitation activity in the next 30 days; percentile 85.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fccv-jmmp-qg76

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46589

Advisory: Apache Tomcat Improper Input Validation vulnerability
IDs: CVE-2023-46589, GHSA-fccv-jmmp-qg76
Record: https://patchnext.com/advisories/cve-2023-46589 (revision 1, source checked 26 Oct 2026, 16:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96; org.apache.tomcat:tomcat-coyote 11.0.0-M11; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.0-M11; >= 10.1.0-M1, < 10.1.16; >= 9.0.0-M1, < 9.0.83; >= 8.5.0, < 8.5.96; fixed in 9.0.83, 8.5.96, 10.1.16, 11.0.0-M11
- Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.0-M11; fixed in 11.0.0-M11
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.0-M11; >= 10.1.0-M1, < 10.1.16; >= 9.0.0-M1, < 9.0.83; >= 8.5.0, < 8.5.96; fixed in 9.0.83, 8.5.96, 10.1.16, 11.0.0-M11

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fccv-jmmp-qg76 (GitHub-reviewed advisory GHSA-fccv-jmmp-qg76 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 <11.0.0-M11)

Commands are suggestions: review each one before running it.

Loading voting…