Skip to content

← Actionable
High, CVSS 8.1amended

AsyncSSH Rogue Session Attack

CVE-2023-46446GHSA-c35q-ffpf-5qpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (asyncssh 2.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI asyncssh

    Affected
    < 2.14.1
    Fixed in
    2.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-46446: 0.87% estimated exploitation activity in the next 30 days; percentile 58.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An issue in AsyncSSH v2.14.0 and earlier allows attackers to control the remote end of an SSH client session via packet injection/removal and shell emulation. Details The rogue session attack targets any SSH client connecting to an AsyncSSH server, on which the attacker must have a shell account. The goal of the attack is to log the client into the attacker's account without the client being able to detect this. At that point, due to how SSH sessions interact with shell environments, the attacker has complete control over the remote end of the SSH session. The attacker receives all keyboard input by the user, completely controls the terminal output of the user's session, can send and receive data to/from forwarded network ports, and is able to create signatures with a forwarded SSH Agent, if any. The result is a complete break of the confidentiality and integrity of the secure channel, providing a strong vector for a targeted phishing campaign against the user. For example,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c35q-ffpf-5qpm

  2. Revision 1 · created ·

    Published from osv record GHSA-c35q-ffpf-5qpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46446

Advisory: AsyncSSH Rogue Session Attack
IDs: CVE-2023-46446, GHSA-c35q-ffpf-5qpm
Record: https://patchnext.com/advisories/cve-2023-46446 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: asyncssh 2.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI asyncssh: affected < 2.14.1; fixed in 2.14.1

## Suggested inspection (read-only)
- `python -m pip show asyncssh`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on asyncssh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c35q-ffpf-5qpm (OSV record GHSA-c35q-ffpf-5qpm lists affected ranges: PyPI asyncssh >=0 <2.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c35q-ffpf-5qpm (GitHub-reviewed advisory GHSA-c35q-ffpf-5qpm lists affected ranges: PyPI asyncssh >=0 <2.14.1)

Commands are suggestions: review each one before running it.

Loading voting…