Skip to content

← Actionable
Medium, CVSS 5.3amended

AsyncSSH Rogue Extension Negotiation

CVE-2023-46445GHSA-cfc2-wr2v-gxm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (asyncssh 2.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI asyncssh

    Affected
    < 2.14.1
    Fixed in
    2.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-46445: 0.59% estimated exploitation activity in the next 30 days; percentile 48.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An issue in AsyncSSH v2.14.0 and earlier allows attackers to control the extension info message (RFC 8308) via a man-in-the-middle attack. Details The rogue extension negotiation attack targets an AsyncSSH client connecting to any SSH server sending an extension info message. The attack exploits an implementation flaw in the AsyncSSH implementation to inject an extension info message chosen by the attacker and delete the original extension info message, effectively replacing it. A correct SSH implementation should not process an unauthenticated extension info message. However, the injected message is accepted due to flaws in AsyncSSH. AsyncSSH supports the server-sig-algs and global-requests-ok extensions. Hence, the attacker can downgrade the algorithm used for client authentication by meddling with the value of server-sig-algs (e.g. use of SHA-1 instead of SHA-2). PoC <details <summaryAsyncSSH Client 2.14.0 (simpleclient.py example) connecting to AsyncSSH Server 2.14.0…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cfc2-wr2v-gxm5

  2. Revision 1 · created ·

    Published from osv record GHSA-cfc2-wr2v-gxm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46445

Advisory: AsyncSSH Rogue Extension Negotiation
IDs: CVE-2023-46445, GHSA-cfc2-wr2v-gxm5
Record: https://patchnext.com/advisories/cve-2023-46445 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: asyncssh 2.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI asyncssh: affected < 2.14.1; fixed in 2.14.1

## Suggested inspection (read-only)
- `python -m pip show asyncssh`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on asyncssh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cfc2-wr2v-gxm5 (OSV record GHSA-cfc2-wr2v-gxm5 lists affected ranges: PyPI asyncssh >=0 <2.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cfc2-wr2v-gxm5 (GitHub-reviewed advisory GHSA-cfc2-wr2v-gxm5 lists affected ranges: PyPI asyncssh >=0 <2.14.1)

Commands are suggestions: review each one before running it.

Loading voting…