Skip to content

← Actionable
High, CVSS 7.5

free5GC udm vulnerable to Invalid Curve Attack

CVE-2023-46324GHSA-cqvv-r3g3-26rf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/free5gc/udm 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-46324: 0.50% estimated exploitation activity in the next 30 days; percentile 43.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

pkg/suci/suci.go in free5GC udm before 1.2.0, when Go before 1.19 is used, allows an Invalid Curve Attack because it may compute a shared secret via an uncompressed public key that has not been validated. An attacker can send arbitrary SUCIs to the UDM, which tries to decrypt them via both its private key and the attacker's public key.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cqvv-r3g3-26rf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46324

Advisory: free5GC udm vulnerable to Invalid Curve Attack
IDs: CVE-2023-46324, GHSA-cqvv-r3g3-26rf
Record: https://patchnext.com/advisories/cve-2023-46324 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/free5gc/udm 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/free5gc/udm: affected < 1.2.0; fixed in 1.2.0

## Suggested inspection (read-only)
- Go github.com/free5gc/udm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/free5gc/udm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cqvv-r3g3-26rf (GitHub-reviewed advisory GHSA-cqvv-r3g3-26rf lists affected ranges: Go github.com/free5gc/udm >=0 <1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…