Next.js missing cache-control header may lead to CDN caching empty reply
CVE-2023-46298GHSA-c59h-r6p8-q9wc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 13.4.20-canary.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 0.9.9, < 13.4.20-canary.13
- Fixed in
- 13.4.20-canary.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c59h-r6p8-q9wc lists affected ranges: npm next >=0.9.9 <13.4.20-canary.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c59h-r6p8-q9wc lists affected ranges: npm next >=0.9.9 <13.4.20-canary.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-46298: 1.61% estimated exploitation activity in the next 30 days; percentile 75.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch responses may sometimes be cached by a CDN, causing a denial of service to all users requesting the same URL via that CDN. Cloudflare considers these requests cacheable assets.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c59h-r6p8-q9wc
- Revision 1 · created ·
Published from osv record GHSA-c59h-r6p8-q9wc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46298 Advisory: Next.js missing cache-control header may lead to CDN caching empty reply IDs: CVE-2023-46298, GHSA-c59h-r6p8-q9wc Record: https://patchnext.com/advisories/cve-2023-46298 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 13.4.20-canary.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 0.9.9, < 13.4.20-canary.13; fixed in 13.4.20-canary.13 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c59h-r6p8-q9wc (OSV record GHSA-c59h-r6p8-q9wc lists affected ranges: npm next >=0.9.9 <13.4.20-canary.13 (fixed)) - Verified: https://github.com/advisories/GHSA-c59h-r6p8-q9wc (GitHub-reviewed advisory GHSA-c59h-r6p8-q9wc lists affected ranges: npm next >=0.9.9 <13.4.20-canary.13) Commands are suggestions: review each one before running it.
Loading voting…