Apache Airflow vulnerable to Exposure of Sensitive Information
CVE-2023-46288GHSA-9qqg-mh7c-chfq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 2.4.0, < 2.7.2
- Fixed in
- 2.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9qqg-mh7c-chfq lists affected ranges: PyPI apache-airflow >=2.4.0 <2.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9qqg-mh7c-chfq lists affected ranges: PyPI apache-airflow >=2.4.0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-46288: 1.84% estimated exploitation activity in the next 30 days; percentile 79.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow. This issue affects Apache Airflow from 2.4.0 to 2.7.0. Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the exposeconfig option is set to non-sensitive-only. The exposeconfig option is False by default. It is recommended to upgrade to a version that is not affected if you set exposeconfig to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7. by specially crafting their request (solved in 2.7.2). Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9qqg-mh7c-chfq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9qqg-mh7c-chfq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46288 Advisory: Apache Airflow vulnerable to Exposure of Sensitive Information IDs: CVE-2023-46288, GHSA-9qqg-mh7c-chfq Record: https://patchnext.com/advisories/cve-2023-46288 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 2.4.0, < 2.7.2; fixed in 2.7.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9qqg-mh7c-chfq (OSV record GHSA-9qqg-mh7c-chfq lists affected ranges: PyPI apache-airflow >=2.4.0 <2.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9qqg-mh7c-chfq (GitHub-reviewed advisory GHSA-9qqg-mh7c-chfq lists affected ranges: PyPI apache-airflow >=2.4.0 <2.7.2) Commands are suggestions: review each one before running it.
Loading voting…