Skip to content

← Actionable
Medium, CVSS 5.1amended

Possible Infinite Loop when PdfWriter(clone_from) is used with a PDF

CVE-2023-46250GHSA-wjcc-cq79-p63f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pypdf 3.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pypdf

    Affected
    >= 3.7.0, < 3.17.0
    Fixed in
    3.17.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.1 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-46250: 0.25% estimated exploitation activity in the next 30 days; percentile 17.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This infinite loop blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage. That is, for example, the case when the pypdf-user manipulates an incoming malicious PDF e.g. by merging it with another PDF or by adding annotations. Patches The issue was fixed with #2264 Workarounds If you cannot update your version of pypdf, you should modify pypdf/generic/datastructures.py just like #2264 did.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wjcc-cq79-p63f

  2. Revision 1 · created ·

    Published from osv record GHSA-wjcc-cq79-p63f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46250

Advisory: Possible Infinite Loop when PdfWriter(clone_from) is used with a PDF
IDs: CVE-2023-46250, GHSA-wjcc-cq79-p63f
Record: https://patchnext.com/advisories/cve-2023-46250 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pypdf 3.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pypdf: affected >= 3.7.0, < 3.17.0; fixed in 3.17.0

## Suggested inspection (read-only)
- `python -m pip show pypdf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pypdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wjcc-cq79-p63f (OSV record GHSA-wjcc-cq79-p63f lists affected ranges: PyPI pypdf >=3.7.0 <3.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wjcc-cq79-p63f (GitHub-reviewed advisory GHSA-wjcc-cq79-p63f lists affected ranges: PyPI pypdf >=3.7.0 <3.17.0)

Commands are suggestions: review each one before running it.

Loading voting…