Skip to content

← Actionable
High, CVSS 7.5amended

incorrect storage layout for contracts containing large arrays

CVE-2023-46247GHSA-6m97-7527-mh74

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    <= 0.3.7
    Fixed in
    0.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-46247: 0.69% estimated exploitation activity in the next 30 days; percentile 52.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact contracts containing large arrays might underallocate the number of slots they need. prior to v0.3.8, the calculation to determine how many slots a storage variable needed used math.ceil(type.sizeinbytes / 32): https://github.com/vyperlang/vyper/blob/6020b8bbf66b062d299d87bc7e4eddc4c9d1c157/vyper/semantics/validation/datapositions.py#L197 the intermediate floating point step can produce a rounding error if there are enough bits set in the IEEE-754 mantissa. roughly speaking, if type.sizeinbytes is large ( 246), and slightly less than a power of 2, the calculation can overestimate how many slots are needed. if type.sizeinbytes is slightly more than a power of 2, the calculation can underestimate how many slots are needed. the following two example contracts can result in overwriting of the variable vulnerable: note that in the latter case, the risk of vulnerable being overwritten is relatively small, since it would cost roughly $1.45 million trillion USD at today's gas prices…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6m97-7527-mh74

  2. Revision 1 · created ·

    Published from osv record GHSA-6m97-7527-mh74

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46247

Advisory: incorrect storage layout for contracts containing large arrays
IDs: CVE-2023-46247, GHSA-6m97-7527-mh74
Record: https://patchnext.com/advisories/cve-2023-46247 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected <= 0.3.7; fixed in 0.3.8

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6m97-7527-mh74 (OSV record GHSA-6m97-7527-mh74 lists affected ranges: PyPI vyper >=0 <0.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-6m97-7527-mh74 (GitHub-reviewed advisory GHSA-6m97-7527-mh74 lists affected ranges: PyPI vyper >=0 <=0.3.7)

Commands are suggestions: review each one before running it.

Loading voting…