Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File
CVE-2023-46245GHSA-fjhg-96cp-6fcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kimai/kimai
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fjhg-96cp-6fcw lists affected ranges: Packagist kimai/kimai >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-46245: 1.80% estimated exploitation activity in the next 30 days; percentile 78.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The laters version of Kimai is found to be vulnerable to a critical Server-Side Template Injection (SSTI) which can be escalated to Remote Code Execution (RCE). The vulnerability arises when a malicious user uploads a specially crafted Twig file, exploiting the software's PDF and HTML rendering functionalities. Snippet of Vulnerable Code: The vulnerability is triggered when the software attempts to render invoices, allowing the attacker to execute arbitrary code on the server. In below, you can find the docker-compose file was used for this testing: Steps to Reproduce (Manually): 1- Upload a malicious Twig file to the server containing the following payload 2- Trigger the SSTI vulnerability by downloading the invoices. 3- The malicious code gets executed, leading to RCE. 4- /tmp/pwned file will be created on the target system I've also attached an automated script to ease up the process of reproducing:
Proof of Concept which can be executed as such: this will download…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fjhg-96cp-6fcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46245 Advisory: Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File IDs: CVE-2023-46245, GHSA-fjhg-96cp-6fcw Record: https://patchnext.com/advisories/cve-2023-46245 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kimai/kimai: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Packagist kimai/kimai: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kimai/kimai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fjhg-96cp-6fcw (GitHub-reviewed advisory GHSA-fjhg-96cp-6fcw lists affected ranges: Packagist kimai/kimai >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…