Skip to content

← Actionable
High, CVSS 8.8

XWiki Platform vulnerable to privilege escalation and remote code execution via the edit action

CVE-2023-46243GHSA-g2qq-c5j9-5w5w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 15.2-rc-1, 14.10.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-46243: 0.98% estimated exploitation activity in the next 30 days; percentile 62.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In XWiki Platform, it's possible for a user to execute any content with the right of an existing document's content author, provided the user have edit right on it. The reason for this is that the edit action sets the content without modifying the content author. To reproduce: Log in as a user without programming or script right. Open the URL <xwiki-host/xwiki/bin/edit/<document/?content=%7B%7Bgroovy%7D%7Dprintln%28%22Hello+from+Groovy%21%22%29%7B%7B%2Fgroovy%7D%7D&xpage=view, where <xwiki-host is the URL of your XWiki installation and <document is the path to a document whose content author has programming right (or script right) and on which the current user has edit right. The text "Hello from Groovy!" is displayed in the page content, showing that the Groovy macro has been executed, which should not be the case for a user without programming right. Patches This has been patched in XWiki 14.10.6 and 15.2RC1. Workarounds There are no known workarounds for it. References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g2qq-c5j9-5w5w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46243

Advisory: XWiki Platform vulnerable to privilege escalation and remote code execution via the edit action
IDs: CVE-2023-46243, GHSA-g2qq-c5j9-5w5w
Record: https://patchnext.com/advisories/cve-2023-46243 (revision 1, source checked 26 Oct 2026, 16:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 15.2-rc-1, 14.10.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 15.0, < 15.2-rc-1; >= 1.0, < 14.10.6; fixed in 15.2-rc-1, 14.10.6

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g2qq-c5j9-5w5w (GitHub-reviewed advisory GHSA-g2qq-c5j9-5w5w lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=15.0 =1.0 <14.10.6)

Commands are suggestions: review each one before running it.

Loading voting…