Skip to content

← Actionable
Critical, CVSS 9.6

XWiki Platform vulnerable to remote code execution via the edit action because it lacks CSRF token

CVE-2023-46242GHSA-hgpw-6p4h-j6h5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 15.2-rc-1, 14.10.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-46242: 0.38% estimated exploitation activity in the next 30 days; percentile 32.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In XWiki Platform, it's possible to execute content with the right of any user if you can make this user follow a crafted URL. This is possible because edit action sets and thereby executes the page content without checking for a cross-site request forgert (CSRF) token. To reproduce: Get a user with programming rights to visit the URL <xwiki-host/xwiki/bin/edit/Main/?content=%7B%7Bgroovy%7D%7Dprintln%28%22Hello+from+Groovy%21%22%29%7B%7B%2Fgroovy%7D%7D&xpage=view, where <xwiki-host is the URL of your XWiki installation. This can be done by embedding an image with this URL. The text "Hello from Groovy!" is displayed in the page content, showing that the Groovy macro has been executed. Patches This has been patched in XWiki 14.10.7 and 15.2-RC-1. Workarounds There are no known workarounds for it. References https://jira.xwiki.org/browse/XWIKI-20386 https://github.com/xwiki/xwiki-platform/commit/cf8eb861998ea423c3645d2e5e974420b0e882be For more information If you have any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hgpw-6p4h-j6h5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46242

Advisory: XWiki Platform vulnerable to remote code execution via the edit action because it lacks CSRF token
IDs: CVE-2023-46242, GHSA-hgpw-6p4h-j6h5
Record: https://patchnext.com/advisories/cve-2023-46242 (revision 1, source checked 26 Oct 2026, 16:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 15.2-rc-1, 14.10.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 1.0, < 14.10.7; >= 15.0, < 15.2-rc-1; fixed in 15.2-rc-1, 14.10.7

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hgpw-6p4h-j6h5 (GitHub-reviewed advisory GHSA-hgpw-6p4h-j6h5 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.0 =15.0 <15.2-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…