CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment
CVE-2023-46240GHSA-hwxf-qxj7-7rfj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/framework 4.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codeigniter4/framework
- Affected
- <= 4.4.2
- Fixed in
- 4.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hwxf-qxj7-7rfj lists affected ranges: Packagist codeigniter4/framework >=0 <=4.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-46240: 0.78% estimated exploitation activity in the next 30 days; percentile 55.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If an error or exception occurs in CodeIgniter4 v4.4.2 and earlier, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Patches Upgrade to v4.4.3 or later. See upgrading guide. Workarounds Replace iniset('displayerrors', '0') with iniset('displayerrors', 'Off') in app/Config/Boot/production.php. For more information If you have any questions or comments about this advisory: Open an issue in codeigniter4/CodeIgniter4 Email us at SECURITY.md
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hwxf-qxj7-7rfj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46240 Advisory: CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment IDs: CVE-2023-46240, GHSA-hwxf-qxj7-7rfj Record: https://patchnext.com/advisories/cve-2023-46240 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codeigniter4/framework 4.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codeigniter4/framework: affected <= 4.4.2; fixed in 4.4.3 ## Suggested inspection (read-only) - Packagist codeigniter4/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codeigniter4/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hwxf-qxj7-7rfj (GitHub-reviewed advisory GHSA-hwxf-qxj7-7rfj lists affected ranges: Packagist codeigniter4/framework >=0 <=4.4.2) Commands are suggestions: review each one before running it.
Loading voting…