browserify-sign upper bound check issue in dsaVerify leads to a signature forgery attack
CVE-2023-46234GHSA-x9w5-v3q2-3rhw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (browserify-sign 4.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm browserify-sign
- Affected
- >= 2.6.0, <= 4.2.1
- Fixed in
- 4.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x9w5-v3q2-3rhw lists affected ranges: npm browserify-sign >=2.6.0 <4.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x9w5-v3q2-3rhw lists affected ranges: npm browserify-sign >=2.6.0 <=4.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-46234: 0.56% estimated exploitation activity in the next 30 days; percentile 46.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An upper bound check issue in dsaVerify function allows an attacker to construct signatures that can be successfully verified by any public key, thus leading to a signature forgery attack. Details In dsaVerify function, it checks whether the value of the signature is legal by calling function checkValue, namely, whether r and s are both in the interval [1, q - 1]. However, the second line of the checkValue function wrongly checks the upper bound of the passed parameters, since the value of b.cmp(q) can only be 0, 1 and -1, and it can never be greater than q. In this way, although the values of s cannot be 0, an attacker can achieve the same effect as zero by setting its value to q, and then send (r, s) = (1, q) to pass the verification of any public key. Impact All places in this project that involve DSA verification of user-input signatures will be affected by this vulnerability. Fix PR: Since the temporary private fork was deleted, here's a webarchive of the PR discussion…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x9w5-v3q2-3rhw
- Revision 1 · created ·
Published from osv record GHSA-x9w5-v3q2-3rhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46234 Advisory: browserify-sign upper bound check issue in `dsaVerify` leads to a signature forgery attack IDs: CVE-2023-46234, GHSA-x9w5-v3q2-3rhw Record: https://patchnext.com/advisories/cve-2023-46234 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: browserify-sign 4.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm browserify-sign: affected >= 2.6.0, <= 4.2.1; fixed in 4.2.2 ## Suggested inspection (read-only) - `npm ls browserify-sign --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on browserify-sign. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x9w5-v3q2-3rhw (OSV record GHSA-x9w5-v3q2-3rhw lists affected ranges: npm browserify-sign >=2.6.0 <4.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-x9w5-v3q2-3rhw (GitHub-reviewed advisory GHSA-x9w5-v3q2-3rhw lists affected ranges: npm browserify-sign >=2.6.0 <=4.2.1) Commands are suggestions: review each one before running it.
Loading voting…