Skip to content

← Actionable
Critical, CVSS 9.1amended

crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard

CVE-2023-46233GHSA-xwcq-pm8m-c4vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (crypto-js 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-46233: 0.64% estimated exploitation activity in the next 30 days; percentile 50.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Summary Crypto-js PBKDF2 is 1,000 times weaker than originally specified in 1993, and [at least 1,300,000 times weaker than current industry standard][OWASP PBKDF2 Cheatsheet]. This is because it both (1) defaults to [SHA1][SHA1 wiki], a cryptographic hash algorithm considered insecure [since at least 2005][Cryptanalysis of SHA-1] and (2) defaults to [one single iteration][one iteration src], a 'strength' or 'difficulty' value specified at 1,000 when specified in 1993. PBKDF2 relies on iteration count as a countermeasure to [preimage][preimage attack] and [collision][collision attack] attacks. Potential Impact: 1. If used to protect passwords, the impact is high. 2. If used to generate signatures, the impact is high. Probability / risk analysis / attack enumeration: 1. [For at most $45,000][SHA1 is a Shambles], an attacker, given control of only the beginning of a crypto-js PBKDF2 input, can create a value which has identical cryptographic signature to any chosen known value.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xwcq-pm8m-c4vf

  2. Revision 1 · created ·

    Published from osv record GHSA-xwcq-pm8m-c4vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46233

Advisory: crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard
IDs: CVE-2023-46233, GHSA-xwcq-pm8m-c4vf
Record: https://patchnext.com/advisories/cve-2023-46233 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: crypto-js 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm crypto-js: affected < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- `npm ls crypto-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on crypto-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xwcq-pm8m-c4vf (OSV record GHSA-xwcq-pm8m-c4vf lists affected ranges: npm crypto-js >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xwcq-pm8m-c4vf (GitHub-reviewed advisory GHSA-xwcq-pm8m-c4vf lists affected ranges: npm crypto-js >=0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…