Skip to content

← Actionable
Medium, CVSS 5.7amended

Werkzeug DoS: High resource usage when parsing multipart/form-data containing a large part with CR/LF character at the beginning

CVE-2023-46136GHSA-hrfv-mqp8-q5rw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (werkzeug 3.0.1, 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI werkzeug

    Affected
    >= 3.0.0, < 3.0.1>= 2.0.0rc1, < 2.3.8
    Fixed in
    3.0.1, 2.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-46136: 1.29% estimated exploitation activity in the next 30 days; percentile 70.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Werkzeug multipart data parser needs to find a boundary that may be between consecutive chunks. That's why parsing is based on looking for newline characters. Unfortunately, code looking for partial boundary in the buffer is written inefficiently, so if we upload a file that starts with CR or LF and then is followed by megabytes of data without these characters: all of these bytes are appended chunk by chunk into internal bytearray and lookup for boundary is performed on growing buffer. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. The amount of RAM required can trigger an out of memory kill of the process. If many concurrent requests are sent continuously, this can exhaust or kill all available workers.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hrfv-mqp8-q5rw

  2. Revision 1 · created ·

    Published from osv record GHSA-hrfv-mqp8-q5rw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46136

Advisory: Werkzeug DoS: High resource usage when parsing multipart/form-data containing a large part with CR/LF character at the beginning
IDs: CVE-2023-46136, GHSA-hrfv-mqp8-q5rw
Record: https://patchnext.com/advisories/cve-2023-46136 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: werkzeug 3.0.1, 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI werkzeug: affected >= 3.0.0, < 3.0.1; >= 2.0.0rc1, < 2.3.8; fixed in 3.0.1, 2.3.8

## Suggested inspection (read-only)
- `python -m pip show werkzeug`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on werkzeug.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hrfv-mqp8-q5rw (OSV record GHSA-hrfv-mqp8-q5rw lists affected ranges: PyPI werkzeug >=3.0.0 =2.0.0rc1 <2.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-hrfv-mqp8-q5rw (GitHub-reviewed advisory GHSA-hrfv-mqp8-q5rw lists affected ranges: PyPI werkzeug >=3.0.0 =2.0.0rc1 <2.3.8)

Commands are suggestions: review each one before running it.

Loading voting…