Skip to content

← Actionable
High, CVSS 7.1

Fabric vulnerable to crosslinking transaction attack

CVE-2023-46132GHSA-v9w2-543f-h69m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hyperledger/fabric 2.5.5, 2.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2023-46132: 0.52% estimated exploitation activity in the next 30 days; percentile 44.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Short summary Combining two molecules to one another, called "cross-linking" results in a molecule with a chemical formula that is composed of all atoms of the original two molecules. In Fabric, one can take a block of transactions and cross-link the transactions in a way that alters the way the peers parse the transactions. If a first peer receives a block B and a second peer receives a block identical to B but with the transactions being cross-linked, the second peer will parse transactions in a different way and thus its world state will deviate from the first peer. Orderers or peers cannot detect that a block has its transactions cross-linked, because there is a vulnerability in the way Fabric hashes the transactions of blocks. It simply and naively concatenates them, which is insecure and lets an adversary craft a "cross-linked block" (block with cross-linked transactions) which alters the way peers process transactions. For example, it is possible to select a transaction and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v9w2-543f-h69m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46132

Advisory: Fabric vulnerable to crosslinking transaction attack
IDs: CVE-2023-46132, GHSA-v9w2-543f-h69m
Record: https://patchnext.com/advisories/cve-2023-46132 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/hyperledger/fabric 2.5.5, 2.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/hyperledger/fabric: affected >= 1.0.0-alpha, < 2.2.14; >= 2.3.0, < 2.5.5; fixed in 2.5.5, 2.2.14

## Suggested inspection (read-only)
- Go github.com/hyperledger/fabric: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/hyperledger/fabric.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v9w2-543f-h69m (GitHub-reviewed advisory GHSA-v9w2-543f-h69m lists affected ranges: Go github.com/hyperledger/fabric >=1.0.0-alpha =2.3.0 <2.5.5)

Commands are suggestions: review each one before running it.

Loading voting…