Skip to content

← Actionable
Medium, CVSS 6.5

Grails data binding causes JVM crash and/or other denial of service

CVE-2023-46131GHSA-3pjv-r7w4-2cf5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.grails:grails-databinding 6.1.0, 5.3.4, 4.1.3, 3.3.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.grails:grails-databinding

    Affected
    >= 6.0.0, < 6.1.0>= 5.0.0, < 5.3.4>= 4.0.0, < 4.1.3>= 2.0.0, < 3.3.17
    Fixed in
    4.1.3, 6.1.0, 3.3.17, 5.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-46131: 0.72% estimated exploitation activity in the next 30 days; percentile 54.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. Patches Patches are available for Grails 3 and later. Workarounds No workaround is possible except to avoid data binding to request data. References - Blog post - Discussion - Mitre CVD record

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3pjv-r7w4-2cf5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46131

Advisory: Grails data binding causes JVM crash and/or other denial of service
IDs: CVE-2023-46131, GHSA-3pjv-r7w4-2cf5
Record: https://patchnext.com/advisories/cve-2023-46131 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.grails:grails-databinding 6.1.0, 5.3.4, 4.1.3, 3.3.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.grails:grails-databinding: affected >= 6.0.0, < 6.1.0; >= 5.0.0, < 5.3.4; >= 4.0.0, < 4.1.3; >= 2.0.0, < 3.3.17; fixed in 4.1.3, 6.1.0, 3.3.17, 5.3.4

## Suggested inspection (read-only)
- Maven org.grails:grails-databinding: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.grails:grails-databinding.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3pjv-r7w4-2cf5 (GitHub-reviewed advisory GHSA-3pjv-r7w4-2cf5 lists affected ranges: Maven org.grails:grails-databinding >=6.0.0 =5.0.0 =4.0.0 =2.0.0 <3.3.17)

Commands are suggestions: review each one before running it.

Loading voting…