Skip to content

← Actionable
Low, CVSS 3.9amended

Fides JavaScript Injection Vulnerability in Privacy Center URL

CVE-2023-46126GHSA-fgjj-5jmr-gh83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.9 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-46126: 0.67% estimated exploitation activity in the next 30 days; percentile 52.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Fides web application allows users to edit consent and privacy notices such as cookie banners. These privacy notices can then be served by other integrated websites, for example in cookie consent banners. One of the editable fields is a privacy policy URL and this input was found to not be validated. The vulnerability makes it possible to craft a payload in the privacy policy URL which triggers JavaScript execution when the privacy notice is served by an integrated website. The domain scope of the executed JavaScript is that of the integrated website. Exploitation is limited to Admin UI users with the contributor role or higher. Patches The vulnerability has been patched in Fides version 2.22.1. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There are no workarounds.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fgjj-5jmr-gh83

  2. Revision 1 · created ·

    Published from osv record GHSA-fgjj-5jmr-gh83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46126

Advisory: Fides JavaScript Injection Vulnerability in Privacy Center URL
IDs: CVE-2023-46126, GHSA-fgjj-5jmr-gh83
Record: https://patchnext.com/advisories/cve-2023-46126 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected < 2.22.1; fixed in 2.22.1

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fgjj-5jmr-gh83 (OSV record GHSA-fgjj-5jmr-gh83 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fgjj-5jmr-gh83 (GitHub-reviewed advisory GHSA-fgjj-5jmr-gh83 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1)

Commands are suggestions: review each one before running it.

Loading voting…