Fides Server-Side Request Forgery Vulnerability in Custom Integration Upload
CVE-2023-46124GHSA-jq3w-9mgf-43m4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.22.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- < 2.22.1
- Fixed in
- 2.22.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jq3w-9mgf-43m4 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jq3w-9mgf-43m4 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2023-46124: 0.84% estimated exploitation activity in the next 30 days; percentile 57.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Fides web application allows a custom integration to be uploaded as a ZIP file containing configuration and dataset definitions in YAML format. It was discovered that specially crafted YAML dataset and config files allow a malicious user to perform arbitrary requests to internal systems and exfiltrate data outside the environment (also known as a Server-Side Request Forgery). The application does not perform proper validation to block attempts to connect to internal (including localhost) resources. Exploitation is limited to API clients with the CONNECTORTEMPLATEREGISTER authorization scope. In the Fides Admin UI this scope is restricted to highly privileged users, specifically root users and users with the owner role. Patches The vulnerability has been patched in Fides version 2.22.1. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There are no workarounds.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jq3w-9mgf-43m4
- Revision 1 · created ·
Published from osv record GHSA-jq3w-9mgf-43m4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46124 Advisory: Fides Server-Side Request Forgery Vulnerability in Custom Integration Upload IDs: CVE-2023-46124, GHSA-jq3w-9mgf-43m4 Record: https://patchnext.com/advisories/cve-2023-46124 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.22.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected < 2.22.1; fixed in 2.22.1 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jq3w-9mgf-43m4 (OSV record GHSA-jq3w-9mgf-43m4 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jq3w-9mgf-43m4 (GitHub-reviewed advisory GHSA-jq3w-9mgf-43m4 lists affected ranges: PyPI ethyca-fides >=0 <2.22.1) Commands are suggestions: review each one before running it.
Loading voting…