Skip to content

← Actionable
Medium, CVSS 5.0amended

yt-dlp Generic Extractor MITM Vulnerability via Arbitrary Proxy Injection

CVE-2023-46121GHSA-3ch3-jhc6-5r8x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2023.11.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    >= 2022.10.4, < 2023.11.14
    Fixed in
    2023.11.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-46121: 0.32% estimated exploitation activity in the next 30 days; percentile 25.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Generic Extractor in yt-dlp is vulnerable to an attacker setting an arbitrary proxy for a request to an arbitrary url, allowing the attacker to MITM the request made from yt-dlp's HTTP session. This could lead to cookie exfiltration in some cases. <details To pass extra control data between extractors (such as headers like Referer), yt-dlp employs a concept of "url smuggling". This works by adding this extra data as json to the url fragment ("smuggling") that is then passed on to an extractor. The receiving extractor then "unsmuggles" the data from the input url. This functionality is intended to be internal only. Currently, the Generic extractor supports receiving an arbitrary dictionary of HTTP headers in a smuggled url, of which it extracts and adds them to the initial request it makes to such url. This is useful when a url sent to the Generic extractor needs a Referer header sent with it, for example. Additionally, yt-dlp has internal headers to set a proxy for a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3ch3-jhc6-5r8x

  2. Revision 1 · created ·

    Published from osv record GHSA-3ch3-jhc6-5r8x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46121

Advisory: yt-dlp Generic Extractor MITM Vulnerability via Arbitrary Proxy Injection
IDs: CVE-2023-46121, GHSA-3ch3-jhc6-5r8x
Record: https://patchnext.com/advisories/cve-2023-46121 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2023.11.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected >= 2022.10.4, < 2023.11.14; fixed in 2023.11.14

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3ch3-jhc6-5r8x (OSV record GHSA-3ch3-jhc6-5r8x lists affected ranges: PyPI yt-dlp >=2022.10.04 <2023.11.14 (fixed))
- Verified: https://github.com/advisories/GHSA-3ch3-jhc6-5r8x (GitHub-reviewed advisory GHSA-3ch3-jhc6-5r8x lists affected ranges: PyPI yt-dlp >=2022.10.4 <2023.11.14)

Commands are suggestions: review each one before running it.

Loading voting…