Skip to content

← Actionable
High, CVSS 7.5amended

Parse Server may crash when uploading file without extension

CVE-2023-46119GHSA-792q-q67h-w579

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 6.3.1, 5.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 1.0.0, < 5.5.6>= 6.0.0, < 6.3.1
    Fixed in
    5.5.6, 6.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-46119: 1.32% estimated exploitation activity in the next 30 days; percentile 70.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Parse Server crashes when uploading a file without extension. Patches A permanent fix has been implemented to prevent the server from crashing. Workarounds There are no known workarounds. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-792q-q67h-w579 - Patched in Parse Server 6: https://github.com/parse-community/parse-server/releases/tag/6.3.1 - Patched in Parse Server 5 (LTS): https://github.com/parse-community/parse-server/releases/tag/5.5.6

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-792q-q67h-w579

  2. Revision 1 · created ·

    Published from osv record GHSA-792q-q67h-w579

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46119

Advisory: Parse Server may crash when uploading file without extension
IDs: CVE-2023-46119, GHSA-792q-q67h-w579
Record: https://patchnext.com/advisories/cve-2023-46119 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 6.3.1, 5.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 1.0.0, < 5.5.6; >= 6.0.0, < 6.3.1; fixed in 5.5.6, 6.3.1

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-792q-q67h-w579 (OSV record GHSA-792q-q67h-w579 lists affected ranges: npm parse-server >=1.0.0 =6.0.0 <6.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-792q-q67h-w579 (GitHub-reviewed advisory GHSA-792q-q67h-w579 lists affected ranges: npm parse-server >=1.0.0 =6.0.0 <6.3.1)

Commands are suggestions: review each one before running it.

Loading voting…