Skip to content

← Actionable
High, CVSS 7.3amended

Prototype Pollution(PP) vulnerability in setByPath

CVE-2023-45827GHSA-9w5f-mw3p-pj47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@clickbar/dot-diver 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-45827: 1.17% estimated exploitation activity in the next 30 days; percentile 67.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There is a Prototype Pollution(PP) vulnerability in dot-diver. It can leads to RCE. Details In this code, there is no validation for Prototpye Pollution. PoC Impact It is Prototype Pollution(PP) and it can leads to Dos, RCE, etc. Credits Team : NodeBoB 최지혁 ( Jihyeok Choi ) 이동하 ( Lee Dong Ha of ZeroPointer Lab ) 강성현 ( kang seonghyeun ) 박성진 ( sungjin park ) 김찬호 ( Chanho Kim ) 이수영 ( Lee Su Young ) 김민욱 ( MinUk Kim )

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9w5f-mw3p-pj47

  2. Revision 1 · created ·

    Published from osv record GHSA-9w5f-mw3p-pj47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45827

Advisory: Prototype Pollution(PP) vulnerability in setByPath
IDs: CVE-2023-45827, GHSA-9w5f-mw3p-pj47
Record: https://patchnext.com/advisories/cve-2023-45827 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @clickbar/dot-diver 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @clickbar/dot-diver: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls @clickbar/dot-diver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @clickbar/dot-diver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9w5f-mw3p-pj47 (OSV record GHSA-9w5f-mw3p-pj47 lists affected ranges: npm @clickbar/dot-diver >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9w5f-mw3p-pj47 (GitHub-reviewed advisory GHSA-9w5f-mw3p-pj47 lists affected ranges: npm @clickbar/dot-diver >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…